Fórum > PHP > Verze PHP

Verze PHP

Autor: michal
Datum: 5.9. 2018 11:19
Dobrý den,

Nedávnou jsem zkoušel jeden eshop software, to ale není podstatné.

Důležité je, že jsem musel použít jiný, protože požadoval php 7.

Proto se chci zeptat, jestli máte někdy v plánu přejít z php 5 na php 7?

Děkuji
Autor: Patrik (patrik-myweb.euweb.cz)
Datum: 5.9. 2018 16:04
Nemluví se o tom tady zatím. Nevadilo-li by vám platit 700Kč/rok (doména+hosting),  tak u forpsi.com si můžete vybrat PHP od 5.2 do 7.1
Autor: michal (cicenka.webzdarma.cz)
Datum: 6.9. 2018 16:14
V pořádku, ten software nepotřebuji. Jen jsem to chtěl, čistě ze zvědavosti, vědět.

I tak děkuji
Autor: Patrik (patrik-myweb.euweb.cz)
Datum: 6.9. 2018 20:08
Aha, dobře. Ještě se uvidí, s čím wz přijde :).

Patrik
Autor: Teddie (Podpora)
Datum: 8.9. 2018 19:11
Dobrý den, aktuálně přechod neplánujeme vzhledem k tomu že u nás běží tisíce aplikací nekompatibilních s php verzi 7 a přechod by je usmrtil.
Autor: Emis (ttauta.wz.cz)
Datum: 11.9. 2018 08:32
Dobrý den, v článku o podpoře uvádíte, že je používáno PHP verze 5.2 nebo 5.6. PHPInfo mi ale zobrazuje verzi 4.4.8. Je možné to nějak přenastavit? 
Autor: Teddie (Podpora)
Datum: 11.9. 2018 19:37
Dobrý den, váš účet se nachází na starom servery. Přechod na nový je možné smazáním účtu a jeho opětovným založením čím se vytvoří na nejnovějším serveru. Před smazáním doporučuji vykonat zálohu obsahu FTP i databáze do vašeho PC.
Autor: Sensei (staradventure.xf.cz)
Datum: 7.12. 2018 10:59
Webzdarma beží na 5.6.23 bohužel :-( 
Autor: Teddie (Podpora)
Datum: 8.12. 2018 22:19
Dobrý den, přechodem na vyšší verzi (7.x) by došlo k nefunkčnosti tisíce stránek protože ne všichni uživatele využívají aplikace které se automaticky aktualizují a tuto verzi podporují., nebo mají stránky napsané ještě mysql syntaxi a museli by překódovat celou jejich aplikaci.
Autor: Patrik (patrik-myweb.euweb.cz)
Datum: 8.12. 2018 23:29
A nešlo by to udělat tak, že by bylo více serverů a na části by bylo PHP 5.x a ne zbytku PHP 7.x? U forpsi.com si můžu přepínat libovolně mezi 5.x a 7.x.

Patrik N
Autor: Radek (tesarstvi-mazac.wz.cz)
Datum: 4.6. 2019 08:09
Uvádíte že je pro přechod z PHP verze 5.2 na 5.6 třeba smazat účet. Bude tedy po tomto kroku moje subdoména volná a bude možné ji znovu použít?

Děkuji.
Autor: Karel (americantrucksimulatoreurotrucksimulator2mpspczsk.wz.cz)
Datum: 30.8. 2019 20:28
Používáte potenciálně nebezpečnou verzi PHP.

Toto píše WordPress. Bylo by moudré pořešit aktualizaci PHP na novější verzi a to bez ohledu na starší verze. Stačí rozeslat upozornění majitelům webů a ty si už zařídí aby jim vše fungovalo. Trochu snahy hoši. 
Autor: Teddie (Podpora)
Datum: 31.8. 2019 16:47
Dobrý den, bohužel na našem webhostingu běží tisíce aplikací které nemusí být s php verzi 7.x kompatibilní. Proto není přechod možné vykonat. Aktualizací by jsme totiž zrušili nespočetné množstvo prezentací které by nefungovali a vykazovali spoustu chyb. 

Pokud vyžadujete php verzi 7.x, doporučuji vám využít jiného webhostingu. Například Stable.cz
Tento web používá k poskytování služeb a analýze návštěvnosti soubory cookie. Používáním tohoto webu s tím souhlasíte. Další informace